Author Topic: Force Thermo time constant and other parameters for PFE EDS acquisitions  (Read 2069 times)

Karsten Goemann

  • Global Moderator
  • Professor
  • *****
  • Posts: 194
All,

I'm now starting to integrate the Thermo EDS into Probe For EPMA on our new JEOL JXA-8530F Plus at UTas. In this particular case I want to set up a method for titanite with major elements (Ca, Ti, Si) on EDS and minors/traces on WDS.

I've started with EDS only (Ca, Ti, Si). Communication between Thermo and PFE seems fine, acquisition, quant etc all good. I've set up a User Defined preset in Thermo Pathfinder to use 20kV range, 3200 ns time constant etc, but when running an automation in PFE Thermo sets the Time Constant to "Auto" after the first point, and then automatically selects Rate 1 (6400 ns), whereas I want to use Rate 3 (3200 ns).

Quant still seems to work OK but the dead times are a bit high for my liking, so I'd like to force it to 3200 ns. Is this possible somehow? The Maximum Energy and Pulse Throughput fields in PFE's Acquisition Options are greyed out.

This is using PFE 11.9.1 and Pathfinder 1.1.

Cheers,
Karsten
« Last Edit: June 05, 2017, 11:11:02 pm by Karsten Goemann »

John Donovan

  • Administrator
  • Emeritus
  • *****
  • Posts: 2487
  • Other duties as assigned...
    • Probe Software
Quant still seems to work OK but the dead times are a bit high for my liking, so I'd like to force it to 3200 ns. Is this possible somehow? The Maximum Energy and Pulse Throughput fields in PFE's Acquisition Options are greyed out.

Hi Karsten,
Yes.  Just set the EDSMaxEnergyThroughputPresent keyword in the Probewin.ini file like this:

EDSMaxEnergyThroughputPresent=-1

john

Edit by John: This keyword also applies to the Bruker Esprit integration with Probe for EPMA
« Last Edit: June 06, 2017, 12:32:16 pm by John Donovan »
John J. Donovan, Pres. 
(541) 343-3400

"Not Absolutely Certain, Yet Reliable"

Karsten Goemann

  • Global Moderator
  • Professor
  • *****
  • Posts: 194
Thanks, that works!

I assume there's no keyword for setting the lower energy cutoff differently to the default (100 eV)? The noise peak seems to extend a little bit further so a value of say 130 eV would probably be better for Range 3. The lower cutoff also automatically changes back to 100eV in Pathfinder after the first point acquisition in PFE...

ThermoNSSVersionNumber="4.0" is still correct for Pathfinder 1.1?

For quantitative WDS and EDS do you actually have to specify a fixed time constant for the EDS acquisition? Even when it automatically reverted back to auto (when I still had EDSMaxEnergyThroughputPresent=0) and automatically changed to 6400nS the results still looked correct in PFE in spite of the primary standards having been acquired at 3200nS.

Cheers,
Karsten


John Donovan

  • Administrator
  • Emeritus
  • *****
  • Posts: 2487
  • Other duties as assigned...
    • Probe Software
Thanks, that works!

I assume there's no keyword for setting the lower energy cutoff differently to the default (100 eV)? The noise peak seems to extend a little bit further so a value of say 130 eV would probably be better for Range 3. The lower cutoff also automatically changes back to 100eV in Pathfinder after the first point acquisition in PFE...

PFE does not do anything with the low energy cutoff for either Thermo or Bruker, but you should be able to configure a project with the modified low energy cutoff in Pathfinder (or Esprit), save it, then re-start PFE and when it asks if you want to specify a project during the initial connection, just select that modified project containing the modified low energy cutoff.  Let me know if that works for you.

ThermoNSSVersionNumber="4.0" is still correct for Pathfinder 1.1?

For the additional features in Thermo Pathfinder you'll want to specify the NSS version as 5.0, so like this:

ThermoNSSVersionNumber="5.0"

I wish they had started with v5 for Pathfinder!    :(

For quantitative WDS and EDS do you actually have to specify a fixed time constant for the EDS acquisition? Even when it automatically reverted back to auto (when I still had EDSMaxEnergyThroughputPresent=0) and automatically changed to 6400nS the results still looked correct in PFE in spite of the primary standards having been acquired at 3200nS.

Cheers,
Karsten

That's a good question.  As you know, the auto time constant mode automatically adjusts the pulse processing time constant to keep the deadtime under 40 percent or so.  I would expect that for a given "live time" one would collect different numbers of photons at different pulse processing rates in the same "live time", but maybe Thermo is doing something more clever than I can think of...
john
« Last Edit: June 07, 2017, 08:13:22 am by John Donovan »
John J. Donovan, Pres. 
(541) 343-3400

"Not Absolutely Certain, Yet Reliable"

Anette von der Handt

  • Global Moderator
  • Professor
  • *****
  • Posts: 244
    • UMN Probelab
Hi Karsten,

the reverting back to the "Auto" time constant is a bug in Pathfinder 1.1 and fixed in Pathfinder 1.2 (the latter version is also way less crash happy).

Cheers,
Anette
Against the dark, a tall white fountain played.

kthompson75

  • Post Doc
  • ***
  • Posts: 11
For Quantitative analysis, Pathfinder and NSS track the actual live time of the data acquisition - whether it is the standard or the unknown. We then use this live time to calculate the total # counts / live-time second / nano-amp. For example, if you are at 50% dead-time and collect for 60 seconds, we would use 30 seconds in the calculation. As a result, the % dead time and / or acquisition time can vary and this is accounted for in the calculation. As a note, we strongly recommend maintaining the same time constant as that impacts the shape of the peaks in the spectrum.

Probeman

  • Emeritus
  • *****
  • Posts: 1955
  • Never sleeps...
    • John Donovan
For Quantitative analysis, Pathfinder and NSS track the actual live time of the data acquisition - whether it is the standard or the unknown. We then use this live time to calculate the total # counts / live-time second / nano-amp. For example, if you are at 50% dead-time and collect for 60 seconds, we would use 30 seconds in the calculation. As a result, the % dead time and / or acquisition time can vary and this is accounted for in the calculation. As a note, we strongly recommend maintaining the same time constant as that impacts the shape of the peaks in the spectrum.

Hi Keith,
That is good to know. I've been wondering about this myself. Thanks for chiming in.
john
The only stupid question is the one not asked!

Probeman

  • Emeritus
  • *****
  • Posts: 1955
  • Never sleeps...
    • John Donovan
Gareth Seward and I have been having a discussion about using the "auto" time constant pulse processing option in Pathfinder. I'm posting this in the Thermo board because I know that Bruker and JEOL EDS systems do not have such a feature (though I am unsure about Oxford or Edax).

Basically if you set the pulse processing time constant in Pathfinder (or NSS) to *zero*, the software will automatically adjust the EDS time constant so that the dead time is always around 40 to 50%. It's sort of nice when one is cruising around a sample where different phases can produce different dead times, or when you're using different beam currents on different samples. But we were wondering what effect it might have on quantitative analysis when utilizing the integrated WDS and EDS acquisition methods in Probe for EPMA. 

Gareth and I came up with several thoughts on this. First, it should be pointed out that because a microprobe has a faraday cup, every time the faraday cup is inserted, the auto time constant mode in Pathfinder thinks "gee, the count rate is really low, I'd better increase the time constant to get better spectral resolution".  But then as soon as the faraday cup comes out, the dead time shoots up to 90% or whatever, and here's the key point: it takes about *15 seconds* for Pathfinder to adjust the time constant back down so that the dead time is back to 40 to 50%.

And second, during automation, by default, as soon as the faraday cup comes out, PFE starts the EDS and WDS acquisition. But here's the thing: as soon as the EDS acquisition is started, Pathfinder *stops* adjusting the time constant, not providing enough time for the auto time constant to adjust for an optimum dead time. This is actually a good thing because Pathfinder has to know what the time constant was utilized over the whole EDS acquisition for spectrum processing (sum peak removal, etc).

But if there hasn't been enough time for the auto time constant to do its thing, and one is running a fairly "hot" beam current condition, the spectrum acquisition dead time might be "frozen" at over 90%, and then the spectrum is not really suitable for quantification.

Now, one can utilize the so-called "decontamination/incubation" time delay feature in PFE, so that after the faraday cup is removed, a user specified delay is implemented (see the Acquisition Options dialog from the PFE Acquire! window for more description). But who wants to wait for 15 seconds for the acquisition to start?

That is why we wondered if simply setting the time constant to some reasonable compromise between count rate and dead time is the best way to go for quant acquisition when using integrated EDS and WDS acquisition.

What do you all think?
The only stupid question is the one not asked!