Author Topic: Jeol version 14 problem with stage mapping  (Read 6102 times)

Ben Buse

  • Professor
  • ****
  • Posts: 432
Jeol version 14 problem with stage mapping
« on: July 13, 2015, 01:08:31 AM »
Following an upgrade of the Jeol software from v12 to v14 the stage mapping ceased to work through Probe Image (the problem has also occurred twice when mapping through the Jeol software - but in over 30 maps).

The problem: Stage mapping starts with a focused beam for the first few pixels of the line then the beam massively defocuses for the rest of the line. It then repeats this for each line, starts focused and then defocuses. This is clearly shown when mapping a mineral which displays luminescence under the electron beam - I've attached a link to a video of it on ZrO2.

https://dl.dropboxusercontent.com/u/34045548/PI_ZrO2_2.mp4

What would be good to know is whether anyone has observed this problem in Jeol v13 or v14.

Version numbers are complex - v14 is PC-EPMA 1.10.1.1 and PC-SEM 3.0.1.13

Thanks

Ben

John Donovan

  • Administrator
  • Emeritus
  • *****
  • Posts: 2790
  • Other duties as assigned...
    • Probe Software
Re: Jeol version 14 problem with stage mapping
« Reply #1 on: July 13, 2015, 08:41:55 AM »
The problem: Stage mapping starts with a focused beam for the first few pixels of the line then the beam massively defocuses for the rest of the line. It then repeats this for each line, starts focused and then defocuses.
Hi Ben,
This sounds (and looks) like an instrument firmware version issue.  Did your firmware also get updated along with the JEOL software?   

I ask because once the mapping app starts an (XY) mapping acquisition, the app no longer has much control over the instrument, except to store the intensity data being returned, or cancel the map.

Another question: I know Probe Image is using the ISMD macro call for stage "area analysis", but does the JEOL also use this macro? Or is it using a set of ILMD stage "line analysis" calls?

Finally does it only occur with the stage mapping or also beam mapping?

In any event it is almost certainly a firmware issue.
John J. Donovan, Pres. 
(541) 343-3400

"Not Absolutely Certain, Yet Reliable"

Ben Buse

  • Professor
  • ****
  • Posts: 432
Re: Jeol version 14 problem with stage mapping
« Reply #2 on: July 14, 2015, 05:41:24 AM »
Hi John,

The upgrade does include a firmware update.

I don't know how the JEOL does it either ISMD or ILMD

The problem only occurs with stage mapping. Beam maps work fine.

Ben

Edit by John: Thanks Ben.  So my money is on a firmware problem in v. 14 of the JEOL software.  Speaking of updates that break things that were working (hey, I do it all the time!), here is a link to a recent Microsoft update that breaks Surfer/Grapher and now I've learned, even equations in Adobe Acrobat:

http://probesoftware.com/smf/index.php?topic=55.msg3029#msg3029

Figures that the security update that broke the GDI drawing in Windows was required, but the update that repairs the damage is "optional"!
« Last Edit: July 14, 2015, 08:48:02 AM by John Donovan »

Ben Buse

  • Professor
  • ****
  • Posts: 432
Re: Jeol version 14 problem with stage mapping
« Reply #3 on: August 27, 2015, 08:26:44 AM »
Just an update, Jeol are looking into what is causing this problem

Ben

Ben Buse

  • Professor
  • ****
  • Posts: 432
Re: Jeol version 14 problem with stage mapping
« Reply #4 on: September 21, 2015, 01:03:31 PM »
Hopefully this will be fixed when Jeol release the next version of their software

Ben

John Donovan

  • Administrator
  • Emeritus
  • *****
  • Posts: 2790
  • Other duties as assigned...
    • Probe Software
Re: Jeol version 14 problem with stage mapping
« Reply #5 on: December 17, 2015, 07:22:47 AM »
I am bumping this topic because Malcolm Roberts at UWA (Perth) was apparently not aware of this JEOL firmware update issue reported above, and after a JEOL software/firmware update during a recent preventative maintenance, he found he now has the same stage mapping bug that Ben reported back in July...  so we're all still waiting for JEOL to fix this problem!

I guess I'm saying that you 8230/8530 JEOL customers are going to have to complain to JEOL directly because they listen to customers more than me!
« Last Edit: December 17, 2015, 07:50:03 AM by John Donovan »
John J. Donovan, Pres. 
(541) 343-3400

"Not Absolutely Certain, Yet Reliable"

Ben Buse

  • Professor
  • ****
  • Posts: 432
Re: Jeol version 14 problem with stage mapping
« Reply #6 on: December 23, 2015, 02:59:17 AM »
Following Shinya Fujita suggestion I did some more tests.

I am now using Probe Image (PI) (part of PFE) 1.2.2.1984.

What I've found is two fold - all using stage scanning:

(1) When jeol PRB scan is initially on. Probe Image now on starting changes the magnification to x15,000. Then it changes it to either a very high magnification beam >>100,000 or to a fixed beam - I can't tell based on fluorescence. During the mapping PRB scan light remains on but at the beginning of some (not all) lines flashes off.

(2) When jeol PRB scan is initially off. Probe Image does not change the initial magnification. It again then changes it to the very high magnification beam/fixed beam. PRB light again remains on & flashes off at the beginning of some lines.

Now the stage mapping fails when the magnification before switching to very high mag/fixed beam is less than between 3000-4000x. 1st few points of each line the beam is very high mag/fixed beam then it massively defocuses (but does not switch to rastering).

I tried the following:

(1) Set magnification on Jeol to x3000, PRB Scan off. Start PI (probe imagE) screen mag stays at 3000x. PRB Light on. Does not work - beam initially very high mag/fixed beam and then beam massively defocuses after 1st few points of each line - see video - https://dl.dropboxusercontent.com/u/34045548/8b.mp4

(2) Set magnification on Jeol to x4000, PRB scan off. Start PI screen mag stays at 4000x. PRB light on. Works fine beam remains at very high mag/fixed beam - see video - https://dl.dropboxusercontent.com/u/34045548/9b.mp4

I also tried: x230 PRB off - failed; x1000 PRB off - failed; x5000 PRB off - works.

It only fails when PRB scanning is turned off when the map is started in probe image. This is beacuse Probe Image now sets the initial magnification to 15,000 when PRB scanning is turned on prior to clicking start in probe image.

An example: Set mag to x230, PRB on. Start PI. It changes the screen magnification to 15,000. Then to the very high mag/fixed beam. And it works.

Many thanks

Ben

John Donovan

  • Administrator
  • Emeritus
  • *****
  • Posts: 2790
  • Other duties as assigned...
    • Probe Software
Re: Jeol version 14 problem with stage mapping
« Reply #7 on: December 23, 2015, 09:11:03 AM »
Hi Ben,
This is very helpful.   It appears from what you are saying that we can get Probe Image to work with the latest JEOL firmware by making sure the instrument is in a specific state before starting the stage scan. That is, it appears to me that we need to set the magnification to over 4000x and then turn off the probe scan before starting our stage scan.  Or just turn on the probe scan first?

Would you agree with this assessment?
john
« Last Edit: December 23, 2015, 09:20:33 AM by John Donovan »
John J. Donovan, Pres. 
(541) 343-3400

"Not Absolutely Certain, Yet Reliable"

Ben Buse

  • Professor
  • ****
  • Posts: 432
Re: Jeol version 14 problem with stage mapping
« Reply #8 on: December 23, 2015, 10:03:24 AM »
Hi John,

For it to work we have two options

(1) Run stage scan without switching to fixed beam on the JEOL beforehand. Click start in PI, PC-SEM screen mag changes to 15,000 & it works.

(2) If you switch to fixed beam on the JEOL beforehand - insure the magnification > 4000x. (For when you click start in PI, the PC-SEM screen remains at the original mag & does not change to 15,000)

So in the default configuration it should work and never fail. Which makes me wonder why it kept failing in July - but that's an aside.

Thanks

Ben
« Last Edit: December 23, 2015, 10:25:01 AM by John Donovan »

Ben Buse

  • Professor
  • ****
  • Posts: 432
Re: Jeol version 14 problem with stage mapping
« Reply #9 on: January 14, 2016, 11:53:30 AM »
Further information regarding the mysterious x15,000 figure.

Today when I set the stage-scan maps going with PRB light on it set the screen to x650 mag (changing it from x300,000) before moving to the very high mag/fixed beam to do the map - and thus failed.

x650 was the specified magnification for beam scan in Probe Image. So when the PRB light is on it seems to set it to the beam scan mag before going to high mag/fixed beam. When I did the test before Christmas this must have been set to x15,000 thus it always worked when PRB light was on.

So today I just turned PRB light off and set the magnification to x300,000 before hitting start (preventing PI changing it to the x650). (I could have I surpose set the beam scan mag to x15000 and it should also have worked - but I didn't have time to test it just now).