Probe Software Users Forum

Hardware => Oxford => Topic started by: Farqhuit on February 14, 2018, 06:58:46 am

Title: Oxford Inca error mesages
Post by: Farqhuit on February 14, 2018, 06:58:46 am
Hi all,

We recently acquired a Hitachi S4000 SEM with an Oxford Pentafet 6566 EDS detector and all associated PCs/towers. We have Inca Issue 17b with SP1 running on - wait for it - Win 2000 Pro. The pulse processor is a tall blue box, model Inca Energy (I think known as an Inca tower). I saw all of this working OK at the old place, and I have been in touch with the previous owners to confirm that they were not having these problems. In tranporting and reinstalling I tried to get all connections identical to how they were before. Here goes...

After the inevitable delay getting everything plumbed in, I now have the scope imaging OK, and I finally have liquid nitrogen for the detector. The scope has all manual stage controls (X, Y, Z, R, T) with all distinctly mechanical readouts. The detector appears to be acquiring spectra perfectly OK, but during acquisition Inca repeatedly chucks out error messages, namely Error 1285[4]. Here's what it says:

"Failed to synthesis requested profile. The sum of elevation, azimuth, and stage tilt is close to zero (less than 1 degree). Please check the angles are correct."

This pops up at least once per second during acquisition (less so during Quant Optimization) and every pop-up needs dismissing (OK button) before anything else is possible. I believe the acquisition continues behind a pop-up, but it does not update the spectrum until the pop-up is dismissed. There is a degree of relief in the Confirm Elements section, but getting there through the pop-ups is a challenge. It seems to me as if the software is expecting the SEM to supply stage data, which I do not believe is possible. If I bring up the Microscope Control dialogue, entering real or made-up numbers for beam kV, WD, X, Y, Z, T, R does not seem to make any difference.

I spoke to Oxford, and they were very helpful (considering this is an obsolete product). He thought also that the software was attempting to automatically read the SEM conditions, and suggested that removing MPOs using the setupscope.exe app from the installation disc should do the trick by stopping Inca from looking for this data. I followed the steps and all went as described/expected, except for a warning at the start:

"The Autostage key is not installed, stage control cannot be installed. If you require stage control then install the autostage key disk."

When I accept the subsequent offer to test the MPOs (after removing them), the resulting box appears to show that default MPOs are present (as expected). However, the same cursed error message continues to pop up in Inca after several attempts at removing MPOs. How can I stop Inca from caring about retrieving these settings? This surely has all the markings of a trivial software issue, as the spectra are fine. Incidentally, I knew of one other S4000 running Inca, where the kV and WD were always entered manually, so I think this is a natural state of affairs.

Some thoughts:

I wonder if it is significant that a banner, "Resetting hardware", always pops up on starting Inca?

The Oxford guy wondered if my Win 2000 privileges were insufficient (there are no warnings to this effect), and hinted that I might be able to edit the registry directly to achieve this.

He also thought that rather than removing MPOs with scopesetup.exe, I might try to get them set up properly. I am not convinced that this facility is available with the mechanical stage of the S4000, but I will look into this.

Would an Inca reinstall help? I am reluctant to do this where I know they have been working OK together, but I am told that ccmdata and installation.ipj files have all the calibration info (might they also contain the problem?).

Finally, I hope that it is OK to post this on here, I wasn't sure if it is just for Probe Software brand users. I have tried to be concise (honestly!) so please ask if any other details might help. I have seen from the other posts that some of you have expertise in these 'older' systems. I will continue to tug at the coat-strings of Oxford, but I think they were running out of ideas. Thanks for reading. Any ideas?

Cheers,

Dave

Edit by John:  Hi Dave.  Perfectly alright for you to post here.  We don't get much interest in Oxford EDS systems, as we currently do not integrate with Oxford. But maybe someone here can help...

Title: Re: Oxford Inca error mesages
Post by: Farqhuit on February 21, 2018, 01:31:44 am
Thanks to those who read the first post. This has moved on since then. The guys at Oxford suggested that the software option for pile-up correction might be causing the error messages (based on a previous case). I tried unchecking this and it didn't change anything, but unchecking the automatic element ID option stopped (almost) the error messages, allowing spectra acquisition blissfully uninterrupted. However, two problems remain.

1. Requesting automatic element ID after the acquisition crashes the Inca software stone dead. This bothers me in as much as I want the software to work properly, but realistically I am not fussed about automatic element ID.

2. Asking for elements to be quantified throws up the 1285[4] error, and returns no quantification data, saying 'No elements analysed'. I had earlier performed Quant Optimization using titanium. Based on limited trial and error experimentation, the Quantification parameters don't seem to make any difference. I will continue to experiment by unchecking all acquisition options (Duane Hunt etc.).

Any suggestions from here very welcome.
Title: Re: Oxford Inca error mesages
Post by: Probe321 on April 10, 2018, 02:41:19 pm
One simple question. Has INCA monitor been ran to calibrate the detector and configure INCA.  I suspect Oxford  had you do this. You should be able to remove the stage MPO with the Microscope control setup software.  If that does not work remove from the registry (had to do that a few times to reinstall MPOs) the INCA disk needs to be in the CD drive.  I am looking at INCA 18d sp5. so some of the names maybe different.  Good luck trouble shooting software can be frustrating.  One other thing check the windows error log to see if the problem is windows related, had that issue with INCA and when it got fixed INCA crashes where greatly reduced.
Title: Re: Oxford Inca error mesages
Post by: Farqhuit on April 12, 2018, 02:30:29 am
Thanks for your comments Probe321. We didn't get as far as a new calibration, though it has been discussed. I can't remember what happened to stop me going ahead, but there must have been something else Oxford wanted me to try first. Calibration is looking like the culprit - I was advised to look for a 'CCDM data' file which was not present, and the CCDM viewer application indicated a lack of calibration. It was suggested to me that if I was logging in under a different account then some stuff might not be available. I think I am using the same account as the previous operators, so it is strange that there is no calibration. I checked the Windows event viewer as you suggested. There were two errors, possibly from every boot up. One has to do with failed non-critical updates or something, but the other is "Windows cannot unload your registry file. If you have a roaming profile, your settings are not replicated. DETAIL - Access is denied. Build number [2195]". There are quite a few other errors, but this seems the most interesting. We are still looking into this, but it looks like a Windows tool called UPHClean might be needed. I can't really see that this is causing calibration data to not load, but I will try to fix it anyway. It can't hurt (famous last words).