Author Topic: Matrix Server Automation Errors  (Read 1664 times)

John Donovan

  • Administrator
  • Emeritus
  • *****
  • Posts: 1969
  • Other duties as assigned...
    • Probe Software
Matrix Server Automation Errors
« on: May 22, 2015, 01:14:35 pm »
There is some evidence that Microsoft Office or operating system updates can cause an existing Matrix COM server installation to fail (normally seen when starting Probe Image).  The error is usually something like this:



Thank-you Microsoft!  We are investigating, but this may be one solution (found on the web):

Alternatively, the manual fix for this problem is to re-register MSCOMCTL.OCX. To do this, follow these steps:

1. Open an administrative-level command prompt. The command prompt MUST be on the administrative level for this to work. Click START, and type RUN in the run command line. On Windows Vista and Windows 7 you will see CMD.EXE appear in the quick search list. Right click CMD.EXE and left click Run As Administrator. A black command prompt opens. On Windows XP, there is no built-in run-as-admin, but you can use the run as menu option (or runas command line) to execute an admin command from a Limited User Account.

2. If on a 64-bit machine, type the following:

regsvr32.exe /u  C:\Windows\SysWOW64\MSCOMCTL.OCX

Hit ENTER

then type

regsvr32.exe  C:\Windows\SysWOW64\MSCOMCTL.OCX

If on a 32-bit machine, type the following:

regsvr32.exe /u C:\Windows\System32\MSCOMCTL.OCX

hit ENTER

then type

regsvr32.exe C:\Windows\System32\MSCOMCTL.OCX
John J. Donovan, Pres. 
(541) 343-3400

"Not Absolutely Certain, Yet Reliable"

Probeman

  • Emeritus
  • *****
  • Posts: 1352
  • Never sleeps...
    • John Donovan
Re: Matrix Server Automation Errors
« Reply #1 on: May 22, 2015, 03:41:42 pm »
It seems that our software uses the file COMCTL32.OCX, so maybe try re-registering that file (in SysWOW64).
The only stupid question is the one not asked!